osha94.com Manual (... updating in progress)

Side Frame

Users are given an option to hide or show the side frame. By default, the side frame will be shown to users. To hide/show the frame, users may click the "Hide Side Frame" or "Show Side Frame" link or menu. Hiding the side frame will give users a wider work space.

Back to Top

Company Information

The first step prior to using other modules in this system should be updating the company information. Upon subscribing, few of the basic information will be set by our support team. These information includes employer's name, company name, email address and telephone number. All these information can be found under "General Information".

As the information will be used throughout the whole data processing, subscribers are advice to update all information. This can be done by clicking the "Edit" link at the bottom of the information page.

Fill in all the required information. For "Industrial Sector", "Company Classification" and "Company Size", click on the "Search" button. This will display all the data and codes prescribed by DOSH.

Example : Table 2 - Industrial Sector

Users may search the description by entering the description in the keyword search box and click the "Search" button. Select the description which best fits the desired information by clicking on the description. The required information will be added into the "Company Information" editing form. Once all the information is completed, click on the "Save" button.

Under the same menu (Company Information), users may see 3 other menus which are: "Department/Location", "Work Area/Process" and "Occupation". These are internal information (not prescribed by DOSH) which will be used in the reports/registers. Clicking on any of these menu will further expand the menu thus displaying the "View" and "Add" menus.

Click on the "View" menu to view all the available information, or click on the "Add" menu to add new information. Alternatively, new information may be added during the data entry process as described in other sections below.

Example : List of Department/Location

To edit existing information, click on the "Edit" link. To delete the existing information, click on the "Del" link.

Example : Adding new Department/Location information form

Fill in all the information and click the "Save" button.

Back to Top

User Manager

The User Manager module allows subscribers to control who and how the information will be shared. Upon subscription, a login ID and password will be emailed to the subscriber. The person named in the subscription application will be given the "Administrator" access level. This will allow the person to add more users under the account. Clicking the "User Manager" menu will display the "View" and Add" menus.

Click on the "View" menu to view all the available users, or click on the "Add" menu to add new users. To edit existing user's information, click on the "Edit" link in the list, and to delete existing user, click on the "Del" link.

Fill in all the required information and assign the login ID, password and appropriate Security Level for the users. Take note of the functions allowed for all the levels. Click the "Save" button to save the information.

If the login ID and/or the password is already being used by other user, a notification will be displayed.

Assign other login ID and/or password.

Back to Top

Activity Calendar

 

This module allows users to publish their activities and programs in a calendar format. To access to this module, click on the 'Activity Calendar' icon located at the top of the side menu.

A new page displaying the calendar will be shown.

 

The calendar page will display all the activities added into the calendar. Moving the mouse over the activity displayed will show the originator of the activity. By clicking on a specific the date, the details of the activities for the respective date will be displayed. If there are activities on the specific date, the information will be displayed. Click the 'Add..New' menu to add new activity. Click on the icon to edit the information and click on the icon to delete. As a security measure, only the originator will be allowed to perform the editing and deletion process.

For empty date, follow the instruction to add new activity

Detail information of activity and main controls

Fill in the title of the activity and the detail description of the activity. If the activity is recurring, choose 'Yes' for recurring. User will be shown the recurrence information control. Select the recurrence frequency (daily, weekly, monthly or annually) and key in the number of recurrence.

User may choose the font color to use and also to set for public or private viewing. The default viewing type is public, which means that all the information will be viewable by all members under the same account.

Back to Top

Policy Statement

The Policy Statement module allows subscribers to publish the OSH Policy Statement over the internet. It also allows hardcopies of the policy statement to be uploaded and viewed. Clicking the "Policy Statement" menu will display the "View" and Add" menus.

Click on the "View" menu to view all the available policies, or click on the "Add" menu to add new policy. To edit existing policy, click on the "Edit" link in the list, and to delete existing policy, click on the "Del" link. Clicking the "Hardcopy" link will display the hardcopy of the policy. If there is no hardcopy exist, an upload form will be displayed.

Click the "Browse" button to browse for the hardcopy. Once done, click the "Confirm" button to upload the hardcopy.

Note: Take note of the hardcopy's file name. DO NOT use 'special' characters such as ' # % and , in the file name.

Adding new Policy Statement and Editing: An editing page will be displayed as shown below. The interface for both Add New and Edit pages are similar with difference on the Add and Update buttons

The controls are very much similar to a common document editing application such as MS Word etc. The image below illustrates the controls for the document editing module. Users may also view each control function by moving the mouse over the control.

Fill in the Policy ID and Date of Creation of the policy. Type in the desired statement in the text area. Once completed : For new statements, click the "Add Data" button. For edited statements, click the "Update" button. Users may print the statement by clicking the "Print" button.

Hint: Users may Cut/Copy and Paste items from external document direct to the text area. This is useful when adding images or to avoid typing into the text area.

Back to Top

Chemical

The Chemical Management module allows subscribers to process data related to chemical safety management. This includes listing chemicals being used, publishing of the Chemical Register,  uploading hardcopies of the MSDS/CSDS, adding chemical supplier information, searching for MSDS and NIOSH (USA)/CDC chemical hazards guidelines (external links), and viewing the CPL hazardous chemicals list.

Note: Suppliers list is a public module, i.e. all suppliers listed/added is available for view by all users.

A. Chemical List

On the top most menu, click on the "View All" menu to view all the available chemicals, or click on the "Add" menu to add new chemical to the list. To edit existing chemicals, click on the "Edit" link in the list, and to delete existing chemical, click on the "Del" link.

Note: Deleting a chemical from the list WILL delete other related information, including existing MSDS/CSDS hardcopies or chemical from the register.

The total number of chemicals available will be displayed and users may browse through the list by clicking the page navigator. A total of 20 chemicals will be listed per page.

Adding new chemical to the list:

Click on the chemical "Add" menu. A chemical information form will be displayed. Ignore the ID number, it is auto-generated by the system.

Users may add all the information: Product Name, Chemical Name, Classification manually, or,

Users may also use the CPL list to add the chemical information by clicking the "Search" button in the Chemical Name row. However, this is suitable for single, non-specialized chemicals not compounds or specialized chemical. Clicking the "Search" button in the Chemical Name row will open a new window to display the CPL chemicals list.

Note: Only Chemicals Hazardous to Health will be displayed.

Users may enter the keyword to search for specific chemical. Searches may be done by the chemical name or its CAS number. Click on the desired chemical name and the information will be transferred to the the chemical information form.

Note: Chemicals with synonyms may not be linked (noted with the statement "...see...". Users are required to search for its common name.
Note: At this point, the window will be programmatically closed, IE may asked for user's permission to close the window. Just click "Yes".

Chemical information transferred

Select the appropriate Physical Form, CSDS Availability and Labels Availability information. Users may edit manually the product name and chemical name if required. Click the "Search" button in the Name of Supplier row to browse for the supplier list. A new window displaying suppliers information will be displayed. Alternatively, users may key in manually the supplier information.

Search for the appropriate supplier and click on the supplier's name to transfer the information to the chemical information form. Users may add new supplier's information by clicking the "Add New" button. A supplier information form will be displayed.

New supplier information form

To add new supplier to the suppliers list, simply fill in all the information and click the "Save" button.

Supplier information transferred to chemical information form

Click the "Save" button to save the chemical information. The Active Ingredients form will be displayed.

The top portion of the form is to add new active ingredient, while the bottom portion is the list of the active ingredients. Users may click the "Del" link to delete the ingredient from the list.

Similar to the addition of chemical above, click the "Search" button to search for chemicals from the CPL chemicals list, or simply add the information manually. Click the "Add Chemical" button to add the active ingredient. Once all the active ingredients is available, click the "Proceed" button.

Adding MSDS/CSDS hardcopy to the chemicals list:

Click on the "MSDS" link of the desired chemical in the chemicals list. A MSDS/CSDS list will be displayed if available.

Users can view the hardcopy by clicking on the desired Document Name, or delete the document by clicking the "Del" link. To add new MSDS/CSDS, click the "Add New" button. An upload form will be displayed.

Assign the document name and click the "Browse" button to browse for the MSDS/CSDS hardcopy. Once done, click the "Confirm" button to upload the hardcopy.

Note: Take note of the hardcopy's file name. DO NOT use 'special' characters such as ' # % and , in the file name.

B. Suppliers List

On the chemical menu, click on the "Supplier" menu to expand it. The "View" and "Add" menus will be displayed. Click the "View" menu to view all the available suppliers, or click on the "Add" menu to add new supplier to the list. To edit existing supplier information, click on the "Edit" link in the list, and to delete existing supplier, click on the "Del" link.

Note: This is a public module. All information is available for viewing by all users regardless of account. Users are advised NOT to edit or delete the information unnecessarily. If there is any duplication, please leave it as it is. Other users may need the information.

Chemical supplier list

Click the "Add" menu to add new supplier. A supplier information form will be displayed.

To add new supplier to the suppliers list, simply fill in all the information and click the "Save" button.

C. Preparation of the Chemical Register

On the chemical menu, click on the "Register" menu to expand it. Two sub-menus will be displayed: "Section A" and "Section B & C". "Section A" will display Section A of the Chemical Register while "Section B & C" is to display Section B and Section C of the Chemical Register.

Section A:

Clicking the "View" menu under "Section A" will display the Section A of the Chemical Register. Users are required to complete the information under "Company Information" - "General Information" in order to get a complete display of the Chemical Register.

Click the "Add Info." menu under "Section A" to complete the Company Activity information. The Company Activity information form will be displayed.

Select the appropriate company activity with regard to usage of chemicals and click the "Save" button.

Section B & C:

Clicking the "View" menu under "Section B & C"  will display a list of areas of which chemical registers have been prepared. To edit existing chemical register, click on the "Edit" link in the list, and to delete existing chemical register, click on the "Del" link.

To view the chemical register in the JKKP format, click the "View" link in the list. The Chemical register will be displayed. To add a new chemical register, click the "Add" menu under "Section B & C". An information form will be displayed.

To add the date, click the icon. This will display a calendar. Select the appropriate date. To add Location of Use and Process Operation, click the button in its respective section. The Location and Process lists will be displayed.

Select the appropriate Location and Process. If information is not available, click the "Add New" button to add new Location and/or Process as described above.

Fill in the number of workers involved in the process, name of the person who prepared the data and the person who reviewed it. Add the date of preparation and review of the chemical register. Click the "Save" button when complete. The chemical list form will be displayed.

The top portion of the form is the chemical list while the bottom portion is the chemical registered for the particular Location/Process. If the required chemical is not in the list, click the "Add New" button to add the new chemical.

Select the desired chemical from the list. The chemical information form will be displayed.

Fill in the required information and click the "Save" button when complete. The chemical will be listed in the register. Repeat the same action until all chemicals in the Location/Process is listed. Click the "Proceed" button when done.

Clicking the "View" link in the chemical register list will display the chemical register (Section B and Section C) in the format prescribed by JKKP.

D. Others

The other submenu links are reference for the chemical management module. These are:

    1. Search MSDS - external link to http://hazard.com/msds/
    2. NIOSH/CDC Guide - page linked to the NIOSH/CDC Chemical Hazard Guidelines pages
    3. CPL List - page listing over 4000 chemicals as listed under the CPL guidelines, with reference to the EC Directives

Back to Top

Document Upload

This module allows subscribers to upload and share hardcopies of documents over the internet. The documents will be stored in osha94.com's server and can be retrieved at any point by the users. Clicking the "Documents Upload" menu will display the "View" and "Add" menus.

Note: This module is designed for documents. Users are recommended to upload only files NOT MORE than 2 MB in size.
Note: Take note of the document's file name. DO NOT use 'special' characters such as ' # % and , in the file name

Click on the "View" menu to view all the available documents, or click on the "Add" menu to upload new document. To edit existing document information, click on the "Edit" link in the list, and to delete existing document, click on the "Del" link. Clicking the "Add" menu will display an upload form.

Click the "Browse" button to browse for the document. Once done, click the "Confirm" button to upload.

Note: This module is designed for documents. Users are recommended to upload only files NOT MORE than 2 MB in size.
Note: Take note of the document's file name. DO NOT use 'special' characters such as ' # % and , in the file name

Back to Top

NADOPOD

The NADOPOD module allows subscribers to process data related to the NADOPOD Regulations as prescribed by the JKKP's guidelines. This includes generation of NADOPOD forms - JKKP6, JKKP7, JKKP8 (I, II, III and IV), JKKP9 and JKKP10. Additional functionalities include uploading of images, charts generation, viewing the list of items from the JKKP NADOPOD Guidelines Tables, guidelines for completing the JKKP8, JKKP9 and JKKP10 forms, guidelines for conducting an Accident Investigation, guidelines for Hazard Identification and guidelines for Hazard Control.

A. Incident Data

On the NADOPOD menu, click on the "Incident Data" menu to view the incident type submenus. Incidents are divided into 2 main types which are Accident/Dangerous Occurrence (DO) and Occupational Poisoning/Occupational Disease (OD). Clicking any of these submenus will further expand the menus showing the "View" and "Add" menus. Users can click on the "View" submenu to view list of recorded incidents or click on the "Add" menu to add new incident to the record. To edit existing incident, click on the "Edit" link in the list, and to delete existing incident, click on the "Del" link. For Accident or Dangerous Occurrence, to display the JKKP6 Form, click the "JKKP6" link and to display the JKKP9 Form, click the "JKKP9" link. For Occupational Poisoning or Occupational Disease click the  "JKKP7" and "JKKP10" links. To add images, click the "Image" link.

Note: Deleting an incident from the list WILL delete other related information, including existing images and JKKP Forms data.

The total number of chemicals available will be displayed and users may browse through the list by clicking the page navigator. A total of 20 chemicals will be listed per page.

Adding new incident data - Accidents/Dangerous Occurrences:

Under the Accident/DO menu, click on the "Add" submenu. An incident information form will be displayed.

By default, Notifier, Notifier Designation, Contact Number, and Organization's Name and Address will be pulled from the Company Information data. Users may add a different information if required. If the Contact Person is different from the Employer named, fill in the Contact Person box and (if required) the Telephone Number.

Select the incident type: Accident or Dangerous Occurrence.

For boxes that are accompanied by the buttons, click on the buttons to display the list of items which corresponds to the related information.

Note: Departmental Location, Actual Location of Incident and Occupation information are the organization's internal information. Users may add, edit or delete items in the list.
Note: Other information are from the JKKP NADOPOD Guidelines, marked with the "Table" column. The "Table" refers to the tables in the guidelines.

Example of Internal Information : Department List

Example of JKKP Table Information : Bodily Location of Injury - Table 12

Users may enter the keyword to search for specific description. Searches may be done by the description or the code. Click on the desired description and the information will be transferred to the the chemical information form. At this point, the window will be programmatically closed, IE may asked for user's permission to close the window. Just click "Yes".

Note: If the actual description is not found, use the most probable description that is the nearest to the desired description.
Note: Take note to use the proper standard terms. For example, to describe the type of injury to the arm: "Broken" is not a standard term. The proper standard term would be "Fracture".

Incident/Case information transferred

To add the date, click the icon to display the date calendar. Select the appropriate date.

To add the time, select the appropriate time of incident (displayed in 24 hours format).

Select if the Date of Report is "APPLICABLE" or "NOT APPLICABLE". "APPLICABLE" is selected if the incident is required to be notified to JKKP (using Form JKKP6). "NOT APPLICABLE" is selected if the incident is not required to be notified to JKKP but only to be recorded (using Form JKKP8).

Fill in the Description of Accident, Nature of Work, the Victim's Name, NRIC/Passport Number, Date of Birth, Gender and Nationality.

Note: For Dangerous Occurrence cases, leave the Affected Person Data section blank. No data entry is required.

Click the "Save" button to save the data.

Adding new incident data - Occupational Poisoning/Occupational Disease:

Refer to the above for details of buttons actions.

Under the Poisoning/OD menu, click on the "Add" submenu. An incident information form will be displayed.

There are 2 types of notifier for Occupational Poisoning/Disease: the Employer or Medical Practitioner. If the notifier is the Employer, fill in the Employer box and clear the Medical Practitioner box, vice-versa. By default, Notifier (Employer or Medical Practitioner), Notifier Designation, Contact Number, and Organization's Name and Address will be pulled from the Company Information data. Users may add a different information if required. If the Contact Person is different from the Employer named, fill in the Contact Person box and (if required) the Telephone Number.

Select the incident type: Occupational Poisoning or Occupational Disease, and fill in the Diagnosis/Provisional Diagnosis.

For boxes that are accompanied by the buttons, click on the buttons to display the list of items which corresponds to the related information.

Note: Departmental Location, Actual Location of Incident and Occupation information are the organization's internal information. Users may add, edit or delete items in the list.
Note: Other information are from the JKKP NADOPOD Guidelines, marked with the "Table" column. The "Table" refers to the tables in the guidelines.

Users may enter the keyword to search for specific description. Searches may be done by the description or the code. Click on the desired description and the information will be transferred to the the chemical information form. At this point, the window will be programmatically closed, IE may asked for user's permission to close the window. Just click "Yes".

Note: If the actual description is not found, use the most probable description that is the nearest to the desired description.
Note: Take note to use the proper standard terms. For example, to describe the type of injury to the arm: "Broken" is not a standard term. The proper standard term would be "Fracture".

To add the date, click the icon to display the date calendar. Select the appropriate date.

To add the time, select the appropriate time of incident (displayed in 24 hours format).

Select if the Date of Report is "APPLICABLE" or "NOT APPLICABLE". "APPLICABLE" is selected if the incident is required to be notified to JKKP (using Form JKKP7). "NOT APPLICABLE" is selected if the incident is not required to be notified to JKKP but only to be recorded (using Form JKKP8).

Fill in the Description of Poisoning/Disease, Nature of Work, the Victim's Name, NRIC/Passport Number, Date of Birth, Gender and Nationality.

Click the "Save" button to save the data.

Adding Data for JKKP9 and JKKP10:

From the incident list, click on the "JKKP9" or "JKKP10" link. A form will be displayed.

JKKP9 consists of 2 pages while JKKP10 consists of 3 pages. Users can view the JKKP Forms by clicking on the desired Page. To add information to the forms, click the "Add Information" link. An information form will be displayed.

JKKP9 Information Form

JKKP10 Information Form

Fill in the required information. For details of the buttons actions, refer above. Some boxes may display information regarding the information such as "DO NOT DELETE the [*] notation mark". These usually appear over boxes which may have more than one information set. Please follow the instructions to ensure correct data processing can take place. the [*] mark will be used to separate the information set.

Click the "Save" button to save the data.

B. Viewing the JKKP Report Forms

JKKP6 and JKKP9:

From the Accident/DO list, click on the "JKKP6" link. The JKKP6 Form will be displayed.

From the Accident/DO list, click on the "JKKP9" link. The JKKP9 Information Form will be displayed. Click "View Page 1" or "View Page 2' to view the respective JKKP9 pages.

JKKP9 Information Form

JKKP7 and JKKP10:

From the Poisoning/OD list, click on the "JKKP7" link. The JKKP7 Form will be displayed.

From the Poisoning/OD list, click on the "JKKP10" link. The JKKP10 Information Form will be displayed. Click "View Page 1", "View Page 2" or "View Page 3" to view the respective JKKP10 pages.

JKKP10 Information Form

C. JKKP8 Report Forms

From the NADOPOD menu, click the "JKKP8" submenu. The list of available JKKP8 data will be displayed.

Users can view the JKKP8 Forms by clicking on the desired JKKP8 page - 8(I), 8(II), 8(III) or 8(IV). To edit the data, click the "Edit" link, or delete the data by clicking the "Del" link. To add new data set for a particular year, click the "Add New" button. An information form will be displayed.

Fill in the required information, the year for the particular data, the average number of employees for the particular year and the total working hours for the particular year. To obtain an accurate statistics, include the overtime or other additional work hours. Click "Save" to save the data. View the JKKP8 Forms by clicking on the desired JKKP8 page - 8(I), 8(II), 8(III) or 8(IV).

By default, the JKKP8 Forms data will be displayed as the description.

To prepare the JKKP8 Forms for submission to JKKP (Form I, Form II and Form III), click the "Use Codes" link. This will convert all the description to codes.

Form JKKP8(I) Description Converted to Code

Form JKKP8(II) Description Converted to Code

Form JKKP8(III) Description Converted to Code

D. Charts

Under the NADOPOD menu, click on the "Charts" submenu to expand it. Click the chart type submenus to display the Chart Viewing Option Form.

Fill in the year to view and click the "View" button. A bar and a pie chart will be displayed.

E. Adding Images

The module allows users to add images to incident cases. On the incident list, click the "Image" link.

If no image exists for the particular case, an image upload form will be displayed.

By default, the information for the image will be pulled from the incident data. Users may add or edit the Note. Click the "Browse" button to browse for the image, and click the "Submit" button to upload the image.

Note: Take note of the image file name. DO NOT use 'special' characters such as ' # % and , in the file name.
Note: The system is not designed for large size images. Upload images with less than 2 MB in size.
Note: The system will display the image in its original dimensions. Users may want to resize the image to obtain a good viewing.

If images exists for the particular case, an image thumbnail will be displayed.

Click on the image or the note to view in its original size. Clicking on the "Images" link on the top will display all available images. Clicking the "Case ID: xx" link will display all images for the particular case.

Users can print the image by clicking the "Print" link, add images by clicking the "Add" link, or delete the image by clicking the "Del" link.

F. Others

The other submenus are reference for the NADOPOD module. These are:

    1. JKKP Tables - items listed in the Tables of the JKKP's NADOPOD Guidelines.
    2. JKKP5 JKKP9, JKKP10 Guides - pages on guidance for completing the JKKP forms
    3. Accident Investigation Guide - page on Accident Investigation
    4. Hazard Identification Guide - page on Hazard Identification
    5. Hazard Control Guide - page on Hazard Control

Back to Top

HIRARC

This module allows subscribers to process data related to HIRARC with reference to the guidelines prescribed by JKKP. This includes listing of possible hazards and its effect and probable control measures.

Click the HIRARC menu to display the "View All", "Add" and "Misc" menus.

Click on the "View All" menu to view all the available HIRARC data, or click on the "Add" menu to carryout new HIRARC process. To edit existing HIRARC data, click on the "Edit" link in the list, and to delete existing document, click on the "Del" link. To view the HIRARC form as per the JKKP prescribed format, click the "View" link.

Clicking the "Add" menu will display a general HIRARC information form.

Click the "Search" button to select the Location and Process information. Fill in the Name and Designation. Click the icon to add the date. Once done, click the "Save" button. The Work Activity form will be displayed. Ignore the ID number, it is auto-generated by the system.

Fill in the Work Activity and click the "Save" button. The Hazard Data form will be displayed.

Users may fill in the Hazard and Effect data manually or click the "Search" button to use the proposed Hazard and Effect.

Hazard Type and Effect List

If users choose to use the proposed Hazard Type and Effect, the Hazard Type and Effect list will be displayed, as shown above. Click on the appropriate hazard to select.

Fill in the Existing Control Measure(s) information and select the appropriate Likelihood and Severity.

Users may fill in the Recommended Control Measure(s) data manually or click the "Guide" button to use the proposed Hazard Control Guide. If users choose to use the proposed Hazard Control Guide, the proposed Hazard Control Measures list will be displayed. If users have chosen to use the proposed Hazard and Effect when entering the hazard data, the list displayed in the Hazard Control Guide will correspond to the specific Hazard Group selected. Otherwise, the whole list of proposed Hazard Control Measure will be displayed.

Proposed Hazard Control List on Specific Hazard Group

All Proposed Hazard Control List Displayed

Click on the appropriate control measure to select.

Fill in the name of the person responsible to implement the control measures and select the date of completion. Select the status of the implementation of the control measures. Click "Add Data" to add the hazard data to the activity.

Repeat the action until all possible hazards have been identified, then click the "Proceed" button. The Work Activity form will be displayed again. This process will continue until all the activities for the particular Location and Process have been identified.

Once completed, click the "View All" submenu under the HIRARC menu to view the HIRARC list, and click the "View" link in the list to display the HIRARC report in the format as prescribed by JKKP.

"View All" submenu

HIRARC Report in JKKP Prescribed Format

To edit the HIRARC data, from the HIRARC list click the "Edit" link. The HIRARC Location/Process data will be displayed. Change the desired data and click the "Save" button. The activity list will be displayed.

To edit the activity, click the "Edit" link, or to delete click the "Del" link. To add another activity click the "Add Activity" button, or if no changes is required, click the "Proceed" button.

When the user clicked on the "Edit" link, the hazard list will be displayed.

To edit the activity, change the activity data and click the "Update" button. To edit the hazard, click the "Edit" link, or to delete click the "Del" link. To add another hazard click the "Add Hazard" button, or if no changes is required, click the "View All" submenu under HIRARC.

The "Misc" submenu links are reference for the HIRARC module. These are:

    1. ILO Occupational Hazard Datasheet - page linked to the ILO Occupational Hazard Datasheet pages
    2. Hazard Identification Guide - page on Hazard Identification
    3. Hazard Control Guide - page on Hazard Control

Back to Top